Virtual Study

25 listopada 2007

Problem przy instalacji z polskim DC

AKTUALIZACJA


Niedawno pojawiło się trochę wątków na forum WSS dotyczących problemów z instalacją Exchange'a 2007 w sieci z kontrolerami domeny na systemach 32-bitowych. Opisałem prawidłową procedurę dla wersji angielskiej systemu, ale nie rozwiązuje to niestety problemów polskich wersji systemów. Sprawdziłem współpracę programu instlacyjnego w najnowszej wersji - Exchange 2007 SP1 RC, zgodnie z zapewnieniami w 99% zgodnej z SP1, który ukaże się już niebawem i niestety skuchasmile_sad. Setup działa poprawnie z kontrolerami domeny w wersji 32-bitowej, ale niestety, dopisanie do pola operatingSystemServicePack słowa "Dodatek" skutecznie blokuje weryfikację wersji Service Packa w lesie Active Directory. W związku z tym trzeba zrobić jedną prostą rzecz:

Tuż przez instalacją (niestety atrybut ten cyklicznie jest aktualizowany) należy zmienić na serwerze pełniącym rolę Schema Master wartość tego atrybutu poprzez wyedytowanie ADSIEditem, lub skryptem - jeżeli będę mieć kolejną wolną chwilę to go na piszę, jeżeli nie to zapraszam do publikacji.

ServicePack1

Tak atrybut wygląda w oryginale, powinien wyglądać tak, jak na poniższym rysunku:

ServicePack

Testy przeprowadzałem na polskiej wersji Windows 2003 Standard SP2 (kontroler domeny), Windows 2008 RC0 - serwer Exchange. Przypomnę, że Exchange 2007 SP1 wymaga wersji systemu co najmniej Windows 2003 SP2.


Niestety Microsoft nadal nie poprawił tego problemu, a ostatnio wrócił znowu.


Czasami powyższa procedura nie pomaga ,trzeba dodatkowo grzebnąć w rejestrach: HKLM/SOFTWARE/Microsoft/WindowsNT/CurrentVersion/CSDVersion też ma powtórzony babol ze słowem "Dodatek". Trzeba wyciąć tak jak wyżej na serwerze schema master i Global Catalogu, z którym gada Exchange - jeżeli nie wiemy, który to serwer, to możemy użyć przy instalacji opcji /dc FQDNkontrolera. I znowu liczy się refleks.




3 komentarze:

basiaw7 pisze...

dzięki :) - bardzo mi pomogłeś tym postem

Konrad Sagala pisze...

Microsoft twierdzi, że dołoży starań, żeby opublikować osobną poprawkę rozwiązującą opisany problem. Zobaczymy...

Pragma pisze...

Witam :)

Chcialbym tylko nadmienic ze problem ten nie dotyczy tylko instalacji Exchange ale w zasadzie wiekszosc produktow z linii System Center ktore podczas instalacji serwera lub agentow sprawdzaja wersje SP na serwerach. Np. SC Data Protection Manager wyrzuca taki blad przy probie instalacji zdalnej agentow na serwerach ktore maja polska wersje jezykowa - jako MCGP zglaszalem ten problem do MS i wiem ze poszedl az do grupy projektowej w Redmond ale rozwiazanie ktore mi przyslali jest dokladnie takie jak opisujesz. Dodam ze czas po ktorym wartosc zmienia sie spowrotem na "dodatek.." to max 2 min dlatego najlepiej jest odpalic setup i czekac z gotowym juz ekranem przed samymi testami.... pozdrawiam. Marek.